RTK Vermessung mit dem Smartphone

  • Hallo allerseits,

    ich hab mir vor 2 Wochen von Ardusimple ein RTK Handheld Kit für brutto 500€ gekauft.


    Mein erstes Problem war dann, dass ich keine Verbindung zu dem F9P herstellen konnte. Im U-center wurde keine Version gefunden.

    Die Lösung war, im U-center auto-bounding einstellen.

    Dann hab ich Lefebure und Locus GIS installiert. Ich hab es mit dem Gastzugang von SAPOS Thüringen probiert, hat aber nicht funktioniert. Hab mir auch RTKnavi auf den Laptop heruntergeladen, da hat der Zugang von SAPOS Thüringen geklappt, allerdings nur mit Wade's voreingestellten Koordinaten.

    Hab mir dann den Zugang für Sapos Bayern bestellt. Da machte ich den Fehler, mir die Servernummer ausm Netz zu suchen, Zugang nicht authorisiert...

    Ein kurzer Anruf beim Servicetelefon konnte das klären. Die richtige Nummer ist 195.200.70.200, der Mountpoint FPS_BY_RTCM3_3G.


    Die Grenzpunkte hab ich mir aus Ibalis in eine Editordatei geschrieben und in QGIS in eine Shape-Datei umgewandelt.

    Diese Datei aufs Smartphone kopiert und mit Locus als Ebene geöffnet.


    Auf freier Prärie stimmt die Genauigkeit mit den Grenzsteine bis auf wenige cm, man merkt sofort jede Bewegung am Bildschirm.

    Im Kiefernwald hatte ich zwar auch teilweise laut Anzeige eine Genauigkeit von 0,01m, aber trotzdem lagen die gefundenen Punkte 1-2m vom Grenzstein weg.

    Man merkt aber auch im Wald, dass Bewegungen in eine Richtung nur sehr träge ankommen, es fehlen wahrscheinlich Satelliten. Eine 5m lange Dachlatte hat zwar meist die Genauigkeit verbessert, aber der Punkt lag trotzdem noch weit vom Grenzstein weg. Ich überlege, ob ich mir eine 8 oder 10m Teleskopstange, die zum Fensterputzen verwendet wird, zulege.

    Viele Dank ans Forum und vor allem an Wade!

  • Hallo

    hier eine Rückmeldung.

    Die Lagegenauigkeit find ich fantastisch. Die Abweichung des Meßstabes aus der Senkrechten hat mehr Auswirkung als die Meßgenauigkeit.

    Also muss man da beim Messen Aufpassen. Das ist aber selbstverständlich.

    Die Höhenmessung passt in sich auch. Aber ich musste die Höhen um ca 50 m korrigieren.

    Habt Ihr eine Idee, warum das so ist?

    Wo könnte man den Korrekturwert am Anfang der Messung eintragen?

  • Bin gerade aus diese Seite gestossen und habe gleich ein paar Fragen.

    Ich möchte auch Grenzen suchen würde aber gerne ersteinmal mit der Software spielen ohne mir das RTK zuzulegen.

    Habe Probleme mir Karten aufs Handy zu laden, ich komme aus Niedersachsen Luftbilder müßten ja umsonst sein, Flurkarten sicher auch Grenzsteindaten wohl nicht.

    Wie und wo laden ich Karten herunter und lege Sie auf dem Handy?

  • Hallo,


    vielen Dank erstmal an die ausführliche Anleitung zum Eigenbau und das Teilen der Infos. Dies ist ein wirklich interessantes und großartiges Projekt.


    Ich würde das System auch gerne benutzen.

    Reicht es aus, den Mountpoint von Thüringen zu nutzen, wie im Video erklärt, um es auch in anderen Bundesländern nutzen zu können?
    Wie genau wäre die Positionsangabe noch, wenn diese in z.b. Rheinland-Pfalz genutzt wird? Eine Genauigkeit von ca. +/- 10-50cm wären für mich zu verkraften.

    Somit müsste ich nicht den Stream aus RLP kaufen. Laut HP Sapos Thüringen, wird nur ein Korrektursignal zurückgegeben, wenn der Mountpoint auch in Thüringen liegt, wie auch im Video angegeben.


    Im nächsten Schritt würde ich gerne die Signale abgreifen, und einen Stellmotor mit dem Lenkrad des Traktors verbinden.

    Ist es möglich, die Daten aus dem Stream abzugreifen und in einer App zwischen zu speichern, sodass diese weiterverarbeitet werden können?

    Falls ja, wie werden die Daten hinterlegt, falls man evntl. über eine Substringmethode diese zerlegen könnte und somit die Abweichung errechnen lassen kann und dieses Signal verarbeitet an den Stellmotor senden kann.


    Gruß,
    Kergam

    • Official Post

    mit 50cm könnte das hinkommen über die Entfernung mit Thüringen. Gibt aber auch kostenlose Ntrip Basis Stationen über Deutschland verteilt, die du über RTK2GO erreichen kannst. siehe hier: RE: rtk2go

    Damit solltest du vermutlich besser zurecht kommen.


    Was genau hast du mit dem Stellmotor vor? Das ist ja im Prinzip ein Lenksystem, da kannst ja einfach Cerea oder Agopengps nutzen, da brauchst nichts eigenes programmieren. Das Korrektursignal hilft dir nicht viel, du brauchst da einfach die fertig NMEA Positionsdaten die der F9P berechnet hat.

  • Hallo,


    hab den gesamten bisherigen Thread-Verlauf gelesen und bin leider noch nicht auf die Lösung meines Problems gestoßen.


    Ich habe die selben Komponenten wie Wade bestellt.

    Ich habe das Firmware-Update auf 1.32 vom F9P gemacht.

    Ich habe Wades Config für F9P und XBEE geladen.

    Ich habe den NTRIP Client wie im Youtube-Video installiert und alle Einstellungen durchgeführt (Bei uns in Österreich heißt der Dienst übrigens APOS und ist für das gesamte Land)


    Bis dahin ist auch alles einfach und gut gelaufen.


    Nun zum Problem:

    Wenn ich "Connect" im NTRIP Client drücke, bekomme ich nur den Output "No DATA".

    LOG:

    Service started

    GPS Mock Location enabled

    Device: RTK_GNSS_440

    Trying to connect...

    Bluetooth Device connected

    Network: Connecting....

    NTRIP: Connected to caster


    Der Ladebalken wird (wie im Video) angezeigt.


    Ist es möglich das die baudrate von XBEE und F9P nicht übereinstimmen und mir das nicht angezeigt wird?

    Welche Möglichkeiten gibt es sonst noch?


    Vielen Dank für eure Hilfe!


    ~ Hubsi

    • Official Post

    Mock location hast du gemacht am Handy?

    Die baudrate kannst mitm ucenter anschauen wenn du den f9p am pc verbindest. Dann auf view, message view, ubx, cfg, prt(port), dort müsste uart 2 die Baudrate auf 115.000 stehen soweit ich mich erinnern kann.

  • Mock location hast du gemacht am Handy?

    Die baudrate kannst mitm ucenter anschauen wenn du den f9p am pc verbindest. Dann auf view, message view, ubx, cfg, prt(port), dort müsste uart 2 die Baudrate auf 115.000 stehen soweit ich mich erinnern kann.

    Wie bereits erwähnt, bin ich deiner Step-by-Step Anleitung auf Youtube 1 zu 1 gefolgt (=also ja, Mock Location ist aktiviert)


    Die Baudrate stimmt ebenfalls. im U-Center kann ich auch eine perfekte Verbindung mit RTK FIX und einer Genauigkeit von 2-3cm erzielen.


    Jedoch scheitert es weiterhin an der Übertragung an den Lefebure NTRIP Client am Android Smartphone. (siehe Bild)

  • Moin zusammen,


    ich hab mir jetzt auch die Bauteile für eine RTK zugelegt, komme aber trotz 3 Tage versuchen nicht ans Ziel.

    Ich hab ein simpleRTK2B Budget und ein WiFi NTRIP Master Board ein gekauft.

    Das simpleRTK2B Board habe ich mit nach der Anleitung von Witt https://www.youtube.com/watch?v=qiYgo25VdD8 configuriert und das XBee WiFi NTRIP nach dieser Anleitung https://www.youtube.com/watch?v=Upp3HWHtxBw&t=324s configuriert. Leider habe ich aber kein Korrektursignal. Die LED für WiFi Hotspot ESP_XBee_660699 blinkt, die LED für das verbundene WLAN (bei mir WiFi HUAWEI-5E93_Guest (OOPEN)) über eine HUAWEI 4G Mobile WiFi Router mit SIM-Karte blinkt auch.


    Im U-Center erreiche ich lediglich ein 3D/DGNS. Die Anzeige für NTRIP Client zeigt : Not connected an. Wenn ich im U-Center den NTRIP-Client mit meinem SAPOS-Zugang füttere und einschalte bekomme ich nach 2 Sekunden ein ein 3D/DGNS/Float.


    Ich möchte das System auf einem Windows 10 Toughbook laufen lassen und mit QGIS oder ähnlichem betreiben. Was mache ich falsch? Wo muss ich suchen / Versuchen / einstellen / etc.?


    Danke im Voraus für eure Hilfe.

  • Wie bereits erwähnt, bin ich deiner Step-by-Step Anleitung auf Youtube 1 zu 1 gefolgt (=also ja, Mock Location ist aktiviert)


    Die Baudrate stimmt ebenfalls. im U-Center kann ich auch eine perfekte Verbindung mit RTK FIX und einer Genauigkeit von 2-3cm erzielen.


    Jedoch scheitert es weiterhin an der Übertragung an den Lefebure NTRIP Client am Android Smartphone. (siehe Bild)

    Ich habe die Lösung für mein Problem gefunden.


    Klingt jetzt etwas dämlich, aber die Lösung war recht einfach und ich möchte sie aufgrund der Vollständigkeit hier ergänzen:


    Im Lefebure NTRIP Client am Smartphone war standardmäßig die Bluetoothverbindung als "Insecure" eingestellt. Ändert man die Einstellung auf "Secure", funktioniert alles sofort.


    Falls sonst noch jemand Probleme bei der Verbindung mit dem Client hat und den Status "No Data" bekommt, versucht es mit dieser Einstellung.


  • Kurzes Update:

    Ich hab alles nochmal geflasht und neu eingestellt und nun läuft alles. Ich bekomme unter OpenSky einen RTK-Fix mit 0,02m in der Höhe und 0,01m in der Ebene. Da bin ich ja positiv überrascht. Die Anzeige in QGIS funktioniert auch problemlos. Und das alles auf einem Toughbook. Was habt ihr den so für Antennen bzw. was habt ihr für einen Antenenphasenzentrumfehler?


    Gruß


    GeoMinister

  • Hallo


    Vielen Dank für die Informationen die Ihr hier teilt!

    Ich hab mir das Ardusimple Set von Mouser.at bestellt und war skeptisch, vorerst...

    Jetzt bin ich begeistert. Verbindung zum Handy und den Lefubure Client am Handy = Zentimetergenaue Grenzsteinsuche !

    Eine kleine Übersicht anbei... ohne Datenimport und Konvertierung... für mich eigentlich nicht notwendig.


    Eine Frage hab ich, welche Karten verwendet ihr eigentlich?


    Gruß Burton